Unable to use the library after update master in git


#1

I have been without update MMG since almost 6 month ago, today I decided to update the master branch. To my surprise, without any change from my side, the code stopping working giving me the following output:

  ## Error: MMG3D_Init_mesh:
 unexpected argument type: 10
Argument type must be one of the MMG5_ARG* preprocessor variable: MMG5_ARG_ppMesh, MMG5_ARG_ppMet,  MMG5_ARG_ppLs, MMG5_ARG_ppDisp

The types of mesh and metric are still the same, so I don’t understand why is not recognising the input.

MMG5_pMesh mmgMesh;
MMG5_pSol  mmgSol;

Thanks in advance


#2

I have seen that in libmmgtypes.h there is a define for MMG5_ARG_end that coincides with 10

#define MMG5_ARG_end    10

#3

Using the “bisection” method I arrive to the conclusion that the last working is the 5.2.6, the next one the 5.3 doesn’t work


#4

Hi,

Is your libmmgtypesf.h file in the src/common directory?
If yes, try to remove it and to reconfigure and rebuild the project.

This file is automatically genereated by Mmg and we have moved its location since the 5.3 release (it is now in the build/src/common directory).

Please, say me if it works.

Regards,

Algiane


#5

I cannot compile if I remove it, and it is still in the master. I attach a screenshot


#6

Hello,

The file you show in the repository is the libmmgtypes.h file which is used to generate the libmmgtypesf.h file.

I suppose that the process that generate the file fails on your PC: can you please send me the results of the cmake and VERBOSE=1 make commands?

For now, you can try to copy the libmmgtypesf.h (20.1 KB) in your build directory (build/src/common) and try to compile without configuring the project (so do not run the cmake command)?

Does it works?

Regards,

Algiane


#7

Finally I just remove everything and start over again all the installation and it worked, sorry for the noise.


#8

No worries,
I am glad that you finally solve your problem!

Regards,