MMGS: remesh of high AR semi-structured mesh


#1

Hi,

I have a structured surface mesh of a ship hull composed of high aspect ratio quads. I have converted the quads to triangles and wish to remesh using MMGS.

However, no faces are split or flipped. MMGS does not change any face. Is there a way to force to an isotropic remeshing?

BTW, brilliant software!

Major


#2

Hi Major,

Thank you for using Mmgs.

It is hard to guess what happens in your case. Normally, you have nothing to do to force Mmgs to modify your mesh.

Which file format are you using?

If you start from the Medit one (.mesh file), maybe you have some required entities? Or the list of the edges of the entire mesh (in Mmg, edges are considered as “boundaries” that can be remeshed but that defines an underlying geometry that must be respected)?

Otherwise, is it possible to attach your mesh please?

Regards,

Algiane


#3

Thanks for your response. I am creating my own MMG5_pMesh from library calls. I include no edges or ridges. It is just vertices and triangular faces.

Attached are an image of the mesh and the mesh in MEDIT format (gzipped).

– PHASE 2 : ISOTROPIC MESHING
** MESH ANALYSIS
** GEOMETRIC MESH
** COMPUTATIONAL MESH

– GRADATION : 1.300000
gradation: 0 updated, 1 iter.
– PHASE 2 COMPLETED. 0.000s

srf.mesh.gz (419.9 KB)


#4

Hi Major,

The mystery is solved : your mesh triangles have negative references. This kind of entities are skipped during the remeshing process. I don’t know what to do about this behaviour (remove it or document it) but it will be discussed with the other Mmg developers.

For now, you can “enable” the remeshing by setting positive references to your triangles.

Regards,

Algiane


#5

Ah, thank you, Algiane. That is good to know and easy to fix! Please keep this highly useful behavior and just document it.


#6

Hi,

Thank you for your feedback. I have added a note on the Mmg website (in the prerequisite section).

Regards