Mmg2d mesh adaption to a solution gives 3d mesh output

Hello, first of all thank you for this tool. Looks very hand and powerful.
I’m a new user so maybe I’m getting it the wrong way. So…
I’m following the tutorial on Mesh adaptation to a solution – Mmg Platform
I download the hole.mesh file, the I run mmg2d_O3 hole.mesh as per the web page. The generation goes fine, then I use gmsh to visualize it. And I get a 3d file:

Which is, of course, quite different from the example.
Is that expected behaviour? Or I am doing something wrong? (16.7 KB)

Indeed the resulting file shows some Z coords are different from zero… let alone the jagged mesh borders…

Thank you for your help

It seems to be a problem in Gmsh visualizing the *.mesh file format, because two-dimensional *.mesh files have no z-coordinate and if you visualize the output file with Medit it looks fine.
Also, if you ask Mmg to save your output in gmsh format by passing the parameter -o hole.o.msh, the visualization in Gmsh is fine.


Ah, glad to hear that. Indeed I’ve tried with Medit and it looks fine.
Thank you for your help. :grinning:

1 Like