Mmg-5.5.2 for Windows - missing vcruntime140d.dll


I was using the mmgs_O3.exe version 5.4.3 for Windows and had some problems using the RequiredEdges keyword. So I wanted to check how the newest binary wok and downloaded the mmg-5.5.2-Windows-10.0.18363-appli.tar.gz from the website.

When I run it it gives me an error of missing the vcruntime140d.dll and ucrtbased.dll. I found the required files (I think they are used for a DEBUG version of the code) put them in the same folder as the mmg executables and tried to start mmgs.exe. I got the error: The application was unable to start correcty…

What can I do?

I was able to test the mmgs version 5.5.1 and the problem with the RequiredEdges is solved. But still the version 5.5.2 does not work.

Dear Matej,
Sorry for the late reply.

Thanks for your feedback. Eventually I have figured out that there has been a wrong configuration of the executable build, and I have rebuilt it.
Could you please try this new one? I have relatively few testing machines for Windows, but it should be OK for Windows 10 and Visual Studio 2015 and newer.

mmg-windows_release.tar.gz (549.7 KB)


Dear Luca,

everything is working now. Thank you.

If you need some more examples of how mmg is used, I am developing a pre- and post-processor on our university called PrePoMax for the finite element method (CalculiX). The mmg is currently used as a .stl shell mesher and as a shell re-mesher.

Kind regards, Matej

Hear Matej,
Of course we would be glad to see how you use Mmg! (Either in the “Share Your Meshes” section or privately, depending on how you feel it of course)