Mesh adaptation to a solution (no geometry)


#1

Hi,
I have an issue with mesh-adaptation on a particoular geometry: hip-stem implant.
I saw that when I used mmg3d_O3 (giving metric and mesh : “mmg3d_O3 mymesh.mesh -sol mysol.sol”) the adaptation procedure was guided by the geometry even where density solution was uniform.
It is possible to impose adaptation based only on the solution (and not on the geometry) ?

Thank you in advance

Monica


#2

Hi Monica,

Welcome in this forum.

You have 2 solutions :

  1. If your surface mesh is already at the size prescribed by the solution, you can try to run with the -nosurf option that forbid the surface modifications (but you will obtain poor qualities if your surface mesh isn’t already at the good size).

  2. Otherwise, if your prescribed size map is sufficiently fine to obtain a good approximation of the geometry, you can try to increase the hausdorff distance parameter (-hausd). By default, it is setted to 0.01, which is a suitable value for meshes with a [0;1]^3 bounding boxe. If you increase the Hausdorff, you authorize to increase the distance between the ideal smooth surface and your surface mesh, thus, the size prescribed by the surface approximation is larger. As we intersect the user sizes with the surface sizes, your size map will applied.

Be careful, Mmg may fail if the Hausdorff parameter is too large (because you authorize to degenerate your boundary approximation).

I hope that it will help, otherwise, do not hesitate to post an image of your output mesh with a description of the unwanted behaviour.

Regards,

Algiane


#3

I increased the hausdorff distance parameter (-hausd) and it works! Then I combine also -nosurf.

Thank you very much!

Monica


#4