Mmg problem with version?


#1

Hello Agliane

could you see the picture attached obtained for a mesh generate by mmg3D but with different version (5.3.11 and 5.4.0),
the top left and top right are obtained without using the required triangle for periodic BC and the down left and down right using the required triangle for periodic BC
I think that you changed the default value for the number of vertices between the two version, cause it seems that there is not enough vertices to build the mesh, how could we specify in the command line the number of vertices that we want to use?

Sincerely
GS

PS: do you have any novel for periodic mesh generation with mmg3D?


#2

Hello,

I think that you are impacted by the new management of the metric along the required entities: it has been introduced in the release 5.4.00 to avoid elements with very bad qualities in the output mesh (and very long CPU time to remesh in some situations).

example of the new management of sizes at required entities:
My input mesh is the following and I ask for a very small size (depicted by the circle). The boundary edges are freezed.
1

The next images show the Mmg v5.3 results (left) and the Mmg v5.4 results (right).
2 4

I don’t know how works your algorithm of parallel/periodic mesh adaptation but maybe the freezed boundaries don’t move enough now we propagate the sizes of the required edges?

I am sorry for this collateral damage.

For the periodic mesh adaptation, I suppose that you have parallel mesh adaptation in mind? (because the periodic one is not yet in our roadmap). For now, the public release of the prallel library is still scheduled in september.

Regards,

Algiane


#3

as you can see in my figures, the problem are inside the mesh and not on the boundary required edges

I don’t deal with parallel mesh generation, and my question was on the generation of periodic mesh in 3D with mmg3D, you told me before that the parallel version of mmg3D will be for September

I want to try mmg3D by increasing the number of vertices but I don’t know how?
in 2D with FreeFem++, I obtain such these result when the nbvx in adaptmesh is not too big

Sincerely
GS


#4

You can’t specify to Mmg the number of vertices that you want to use, you can only provide a size map that will prescribe at each nodes the wanted edge size.

You can try to disable the required gradation (-hgradreq -1 or MMG3D_Set_dparameter ( mesh, met, MMG3D_DPARAM_hgradreq, -1 ) in API mode). Otherwise, is it possible to send me your mesh, metric and the reference of the freezed boundaries?

Thank you by advance,

Algiane


#5

here are the mesh already obtained after freezing boundary :
http://georges-sadaka.fr/To_Send/ThBackupReqTri.mesh
and the metric :
http://georges-sadaka.fr/To_Send/ThBackup.sol

and here are the parameter I used :
~/mmg/build/bin/mmg3d_O3 ThBackupReqTri.mesh -out ThBackupo.mesh -sol ThBackup.sol -hmin .05 -hmax 2 -hgrad 2.3 -v 3

Sincerely
GS


#6

It’s OK when using -hgradreq -1
here are the result!

Thanks again


#7

Hello,

I will continue to investigate a little as I do not understand why the sizes are propgated so far from the required entities.

I will keep you aware,

Regards,
Algiane